Support Forum

Ask questions and get help from MobileTogether experts.
MobileTogether Product Information
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
nigel  
#1 Posted : Monday, March 13, 2017 11:04:44 AM(UTC)
nigel

Rank: Advanced Member

Groups: Registered
Joined: 1/20/2017(UTC)
Posts: 59
United Kingdom
Location: sussex

Thanks: 1 times
I am testing a text value on the first run through eg Visible when hilo = 'Hi' and this works without any problems. If I then save the data to an sql server and retrieve it later for editing then the same test will always return false. I can get round this by using contains and I am assuming the the data loaded from the sql database pads out the text in the persistent data when it is loaded so it is not an exaxt match. Is there an easy way round this, or is this just the way the software works ?
bbv  
#2 Posted : Monday, March 13, 2017 11:35:46 AM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 495

Was thanked: 87 time(s) in 87 post(s)
1. You should be able to see the actual data during simulation - no need to guess whether this is a padding issue. It is important to understand what you have before trying to workaround here.

2. Not MobileTogether will add spaces when loaded from database, but the database itself. This happens if you are using CHAR type to save text in the database. Use VARCHAR to save it without spaces

3. If it is really padding, and you still have no idea what is happening, you can help yourself by using trim-string function which will remove leading and trailing spaces, i.e. trim-string( hilo ) = 'Hi'
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.