Support Forum

Ask questions and get help from MobileTogether experts.
MobileTogether Product Information
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Daniele G.  
#1 Posted : Tuesday, September 9, 2014 11:54:25 AM(UTC)
Daniele G.

Rank: Member

Groups: Registered
Joined: 9/5/2014(UTC)
Posts: 15
Italy

Thanks: 9 times
I have succesfully created a solution to query and edit a simple MySQL database table.
I've found MobileTogether very easy to use even with my lack of experience.

In the "New Table" wizard I have checked the "Automatic Append/Delete controls".

When I simulate the solution, both "+" and "-" icons are present:
Simulated Solution
and their actions correctly reflect on data stored in MySQL table.

When i deploy the solution on MobileTogether server and load it from MobileTogether client app on an iPhone4, "+" button is still present and working, but "-" buttons are not present at the left of each line:
Deployed Solution (iPhone 4)
so i can add and edit rows, but not delete them.

Have I missed something or is it an issue of the beta version?

bbv  
#2 Posted : Tuesday, September 9, 2014 12:10:24 PM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 480

Was thanked: 81 time(s) in 81 post(s)
We have chosen not to show (-) symbols because of the very small visual area on iPhone. We are using a standard method for iPhone to delete rows - swiping to the left.
thanks 1 user thanked bbv for this useful post.
Daniele G. on 9/22/2014(UTC)
Daniele G.  
#3 Posted : Tuesday, September 9, 2014 12:41:08 PM(UTC)
Daniele G.

Rank: Member

Groups: Registered
Joined: 9/5/2014(UTC)
Posts: 15
Italy

Thanks: 9 times
Thank you very much for answering so quickly. Swiping to the left works!

(Before your answer I had tryed swiping, but - I don't know why - only to the right)
Daniele G.  
#4 Posted : Tuesday, September 9, 2014 12:54:02 PM(UTC)
Daniele G.

Rank: Member

Groups: Registered
Joined: 9/5/2014(UTC)
Posts: 15
Italy

Thanks: 9 times
In the same solution I have noticed that, after entering a new row, if I accidentally tap "Submit" twice the new row is inserted twice in the database table.

Is there a way to prevent this?
bbv  
#5 Posted : Tuesday, September 9, 2014 2:57:21 PM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 480

Was thanked: 81 time(s) in 81 post(s)
This is already fixed for an upcoming release
thanks 1 user thanked bbv for this useful post.
Daniele G. on 9/22/2014(UTC)
Daniele G.  
#6 Posted : Tuesday, September 9, 2014 3:47:33 PM(UTC)
Daniele G.

Rank: Member

Groups: Registered
Joined: 9/5/2014(UTC)
Posts: 15
Italy

Thanks: 9 times
Great! Thank you
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.