Support Forum

Ask questions and get help from MobileTogether experts.
MobileTogether Product Information
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Philip Michael  
#1 Posted : Tuesday, December 31, 2019 7:46:44 PM(UTC)
Philip Michael

Rank: Member

Groups: Registered
Joined: 12/31/2019(UTC)
Posts: 16
United States
Location: Missouri

Thanks: 3 times
I have a Solution that is crashing on one particular iPhone XS, but doesn't crash on other iPhones. It also works with other iPhone XS phones, just not this particular phone. The Solution and the MobileTogether app both crash and there are no errors in the logs on the MobileTogether server. The crash happens when a button is clicked. It is set to open a tabbed page on click. I've even tried a blank page from the button click, but it still crashes. It only happens on one page and I've even tried adding another button that opens a blank page and it still happens. Are there any other logs I can look at to help me or is there something else I can do to try and figure out why this is happening?
MIP  
#2 Posted : Tuesday, January 7, 2020 10:00:27 AM(UTC)
MIP

Rank: Member

Groups: Registered
Joined: 7/22/2019(UTC)
Posts: 11
Austria
Location: Vienna

Was thanked: 3 time(s) in 3 post(s)
Hi,

Is there an operating system difference? any difference in visualization? maybe this one is in dark mode and all others in light mode or vice versa?

My thought however is, that there is some persistent data set that is accessed with this button click and that this data is different for this one phone. could this be?

How to get crash log on your iOS device:

go to Settings / Privacy / Analytics / Analytics Data
Find MobileTogether
Tap the log
Tap the share icon so you can send it

best regards
Philip Michael  
#3 Posted : Tuesday, January 7, 2020 10:00:55 PM(UTC)
Philip Michael

Rank: Member

Groups: Registered
Joined: 12/31/2019(UTC)
Posts: 16
United States
Location: Missouri

Thanks: 3 times
Hi MIP,
The OS is the same (Latest) on all the phones we tested. There were phones set to dark mode and we changed them to normal and I also set the project to "Enforce Light Theme" to true. We tried the exact steps to reproduce the error on each phone and only the one had the issue. I don't see a way to attach a file unless it asks me when I check the "Attach files to this post?" and I click the "Post" button? If not, I will try to reply again and copy the text of the log (as much as I can) into the post.
File Attachment(s):
MobileTogether-2020-01-07-132018.ips (86kb) downloaded 8 time(s).
MIP  
#4 Posted : Monday, January 13, 2020 10:58:33 AM(UTC)
MIP

Rank: Member

Groups: Registered
Joined: 7/22/2019(UTC)
Posts: 11
Austria
Location: Vienna

Was thanked: 3 time(s) in 3 post(s)
Hi,

Thanks for the dump.
Although i could not reproduce the crash, it helped narrowing down.

But i'd like to be able to reproduce the crash before saying it will be/was fixed -
in the accessability options on the crashing phone:
is there a larger/smaller font, some visual helps like contrast, button shapes,...?

best regards
Philip Michael  
#5 Posted : Friday, February 7, 2020 9:34:10 PM(UTC)
Philip Michael

Rank: Member

Groups: Registered
Joined: 12/31/2019(UTC)
Posts: 16
United States
Location: Missouri

Thanks: 3 times
Hi MIP,
It looks like the only difference was "Larger Text" was turned On under Settings\Accessibility\Display & Text Size. Once that was turned off it started working correctly. Now what do we need to do in case someone has that turned on? Is there something in the App I can change so it isn't affected by this? Sorry for getting back so late. The person who has the phone was involved in the NFL Superbowl and just became available again. Thanks for any help.
MIP  
#6 Posted : Monday, February 10, 2020 7:30:44 AM(UTC)
MIP

Rank: Member

Groups: Registered
Joined: 7/22/2019(UTC)
Posts: 11
Austria
Location: Vienna

Was thanked: 3 time(s) in 3 post(s)
Hi,

thanks for narrowing it down.
however i've tested with "larger text" since i assumed something like this when it only happens on a specific phone.
can you maybe share the design + precise screenshot (larger text has a selection slider on bottom of the screen) of the accessibility options either here or via altova support?

thanks and best regards
MIP
thanks 1 user thanked MIP for this useful post.
Philip Michael on 2/12/2020(UTC)
Philip Michael  
#7 Posted : Wednesday, February 12, 2020 7:51:55 PM(UTC)
Philip Michael

Rank: Member

Groups: Registered
Joined: 12/31/2019(UTC)
Posts: 16
United States
Location: Missouri

Thanks: 3 times
Hi MIP,
The text was set to default on the slider which appears to be the middle. We have tried all the settings on the slider and now we can't reproduce the issue. There must have been something that got corrupted and was fixed by toggling the Text Size on/off on the iPhone. Thanks for your help in getting us this far.
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.