Support Forum

Ask questions and get help from MobileTogether experts.
MobileTogether Product Information
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
jan  
#1 Posted : Thursday, October 7, 2021 12:53:15 PM(UTC)
jan

Rank: Newbie

Groups: Registered
Joined: 5/26/2021(UTC)
Posts: 6
Czech Republic

Hi,
my app works fine on Windows client (with camerra). Works on local simulator too.
Only when i deployed to Android device stuck after action.

File Attachment(s):
EleckrodyFail.mtd (82kb) downloaded 1 time(s).
AFC  
#2 Posted : Friday, October 8, 2021 6:08:28 AM(UTC)
AFC

Rank: Administration

Groups: Registered, Administrators
Joined: 9/15/2014(UTC)
Posts: 121
Austria

Was thanked: 16 time(s) in 16 post(s)
Hi Jan!

Quote:
...stuck after action.

Which action are you talking about? Any steps how to reproduce?
Which MobileTogether and Android version are you using?

Maybe you can also give us a test database and your global resource file for being able to better reproduce your issue?
In case you don't want to post this here, please contact Altova Support.
jan  
#3 Posted : Friday, October 8, 2021 6:27:11 AM(UTC)
jan

Rank: Newbie

Groups: Registered
Joined: 5/26/2021(UTC)
Posts: 6
Czech Republic

Hi,
action on Button4. There is no writing to database.
MT is 7.3 (x64).
Android 12, Pixel5, MT 7.3
Android 7, Galaxy Tab S2, MT 7.3
jan attached the following image(s):
LostFieldsRefresh-stuck prg.png
AFC  
#4 Posted : Friday, October 8, 2021 6:37:46 AM(UTC)
AFC

Rank: Administration

Groups: Registered, Administrators
Joined: 9/15/2014(UTC)
Posts: 121
Austria

Was thanked: 16 time(s) in 16 post(s)
Hi jan!

So it stucks before/during/after barcode scanning? Do you scan in landscape or portrait mode?
Or does your issue happen later on when playing the Audio?

Even if no DB writing is done, we cannot run the sample without DB (so an empty one would already be helpful).
jan  
#5 Posted : Friday, October 8, 2021 7:00:28 AM(UTC)
jan

Rank: Newbie

Groups: Registered
Joined: 5/26/2021(UTC)
Posts: 6
Czech Republic

App stuck after action (open cammera, scan code, beep (OK)) Scan on Portrait. In this action is only update NODE, no writing/save to DB.
AFC  
#6 Posted : Friday, October 8, 2021 7:48:40 AM(UTC)
AFC

Rank: Administration

Groups: Registered, Administrators
Joined: 9/15/2014(UTC)
Posts: 121
Austria

Was thanked: 16 time(s) in 16 post(s)
Hi jan!

Not sure what exactly you mean with "stuck"? Does your app not respond anymore and you must kill it? Do you miss UI or data updates?,...?

just an idea when really "update NODE" is your problem: at the end of this action tree on Button4, you make an
Quote:
Update Node(s): $DB2/DB/RowSet/Row/@Vo
with Result of: $PERSISTENT/Root/VO

When $DB2 has no Row element, the update will fail.
You would need an "Append Node" action in this case.

Can this be your problem?
jan  
#7 Posted : Friday, October 8, 2021 8:19:30 AM(UTC)
jan

Rank: Newbie

Groups: Registered
Joined: 5/26/2021(UTC)
Posts: 6
Czech Republic

stuck, mean not more respond with user, UI lost images, you can see on attached images (win client works fine, as I want)
jan attached the following image(s):
WinClientAfterScan-OK.png
Android-more-touches-UIFreeze-notRespond.png
AndroidClientAfrerScan-lost-Fields-Buttons.png
AFC  
#8 Posted : Friday, October 8, 2021 8:26:20 AM(UTC)
AFC

Rank: Administration

Groups: Registered, Administrators
Joined: 9/15/2014(UTC)
Posts: 121
Austria

Was thanked: 16 time(s) in 16 post(s)
Hi jan!

I think best would be you contact the (free) Altova Support.
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.