Support Forum

Ask questions and get help from MobileTogether experts.
MobileTogether Product Information
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
JMac  
#1 Posted : Thursday, July 7, 2016 3:30:39 AM(UTC)
JMac

Rank: Newbie

Groups: Registered
Joined: 7/5/2016(UTC)
Posts: 6
Australia
Location: Melbourne

Thanks: 4 times
I have made a simple app which I would like to make available on browser view for non-technical people to quickly use without having to install anything. It is served on Windows Server using an sqlite3 database. This works on a PC browser (don't know about Mac) but flashes repeatedly, as if refreshing the data, on an iPhone or iPad. Sometimes the flashing results in the table being scrolled back up to the top. This happens while attempting to enter data and may cause the data to be cleared from the field. It's unusable, basically.

The data is in the form of an entire table from the database, with the fields from each record represented by Edit Fields which span multiple lines for each record. Users are supposed to scroll down to the record of choice, and edit the entry there. The time period between flashes seems variable.

What might be the problem?

I appreciate your help in advance!

Best regards,

James
bbv  
#2 Posted : Thursday, July 7, 2016 10:58:06 AM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 495

Was thanked: 87 time(s) in 87 post(s)
Hi James,

can you attach your design file with a sample database here (or send them to Altova Support if you cannot make it public). Based purely on your description everything should be just fine.
JMac  
#3 Posted : Monday, July 11, 2016 12:48:02 AM(UTC)
JMac

Rank: Newbie

Groups: Registered
Joined: 7/5/2016(UTC)
Posts: 6
Australia
Location: Melbourne

Thanks: 4 times
Thanks for the response. Files attached.

Best regards,

James
File Attachment(s):
Rego.mtd (14kb) downloaded 45 time(s).
gr_rego.sqlite3 (8kb) downloaded 41 time(s).
bbv  
#4 Posted : Monday, July 11, 2016 9:00:17 AM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 495

Was thanked: 87 time(s) in 87 post(s)
Thanks. Just to be sure I got you right: when executed in Browser, it flashes, whereas when running on iPad or iPhone - everything is fine. Correct? Or was it the other way around?
JMac  
#5 Posted : Tuesday, July 12, 2016 12:28:56 AM(UTC)
JMac

Rank: Newbie

Groups: Registered
Joined: 7/5/2016(UTC)
Posts: 6
Australia
Location: Melbourne

Thanks: 4 times
No it is the other way round. The iphone and ipad flashes. A normal browser on a PC (eg Internet Explorer 11) is steady as a rock. Do you need the .png file? Maybe that is something to do with it.

Best regards,

James
bbv  
#6 Posted : Tuesday, July 12, 2016 9:00:45 AM(UTC)
bbv

Rank: Administration

Groups: Registered, Administrators
Joined: 7/21/2014(UTC)
Posts: 495

Was thanked: 87 time(s) in 87 post(s)
ok, thanks. We've been able to reproduce this issue - something to do with Safari browser. Have to investigate internally.
thanks 1 user thanked bbv for this useful post.
JMac on 7/19/2016(UTC)
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.